summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicolas Williams <nico@cryptonector.com>2015-10-27 19:01:06 -0500
committerNicolas Williams <nico@cryptonector.com>2015-10-27 20:06:21 -0500
commit8f115e9eed8e71816b9f3a86e0d3aabd47a750d9 (patch)
treef4631abbc843cc80b1cea12a8d126ac6d5e3b52d /Makefile.am
parente17ccf229723d776c0d49341665256b855c70bda (diff)
Add address sanitizer (ASAN) support (fix #1002)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 01a7ed12..327dc6d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,11 +54,16 @@ include_HEADERS = src/jv.h src/jq.h
### Running tests under Valgrind
+if ENABLE_ASAN
+AM_CFLAGS += -fsanitize=address
+NO_VALGRIND = 1
+else
if ENABLE_VALGRIND
NO_VALGRIND =
else
NO_VALGRIND = 1
endif
+endif
### Code coverage with gcov