summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicolas Williams <nico@cryptonector.com>2016-01-15 16:06:30 -0600
committerNicolas Williams <nico@cryptonector.com>2016-01-16 16:51:01 -0600
commitec07936888b845c608a0d63aa833a91844efde0c (patch)
tree112e7425902521e10952ea20def83ba47bc57b1c /Makefile.am
parent8e4724e16cf681126a4dc5f288e30b7926ed35b2 (diff)
Fix Windows build (fix #911)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ec4dbc9..83f99071 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,6 +50,10 @@ libjq_la_SOURCES = ${LIBJQ_SRC}
libjq_la_LIBADD = -lm
libjq_la_LDFLAGS = -export-symbols-regex '^j[qv]_' -version-info 1:4:0
+if WIN32
+libjq_la_LIBADD += -lshlwapi
+endif
+
include_HEADERS = src/jv.h src/jq.h
### Running tests under Valgrind