summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicolas Williams <nico@cryptonector.com>2016-01-15 16:06:18 -0600
committerNicolas Williams <nico@cryptonector.com>2016-01-15 16:06:18 -0600
commit8e4724e16cf681126a4dc5f288e30b7926ed35b2 (patch)
tree093f48534f020454f7789f4fae61f6fbbd017f4b /Makefile.am
parent3afdbb7b7d013da8a7f56e4eaa1a54e1b0edbee1 (diff)
fixup non-maintainer build
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a9b5b543..3ec4dbc9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,7 +31,7 @@ src/lexer.c: src/lexer.l
$(AM_V_LEX) flex -o src/lexer.c --header-file=src/lexer.h $<
src/lexer.h: src/lexer.c
else
-BUILT_SOURCES = src/builtin.inc
+BUILT_SOURCES = src/builtin.inc src/version.h
.y.c:
$(AM_V_YACC) echo "NOT building parser.c!"
.l.c:
@@ -140,7 +140,8 @@ DOC_FILES = docs/content docs/public docs/templates docs/site.yml \
EXTRA_DIST = $(DOC_FILES) $(man_MANS) $(TESTS) $(TEST_LOG_COMPILER) \
jq.1.prebuilt jq.spec src/lexer.c src/lexer.h src/parser.c \
- src/parser.h scripts/version tests/jq.test tests/modules/.jq \
+ src/parser.h src/version.h src/builtin.inc \
+ scripts/version tests/jq.test tests/modules/.jq \
tests/modules/a.jq tests/modules/b/b.jq tests/modules/c/c.jq \
tests/modules/c/d.jq tests/modules/data.json \
tests/modules/lib/jq/e/e.jq tests/modules/lib/jq/f.jq \