summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-11-21 08:30:41 -0500
committerDrew DeVault <sir@cmpwn.com>2018-11-21 08:30:41 -0500
commit3f532d8110f0e7908d4a45a42c795549efc87388 (patch)
treef8ab4851c1da9d94e3a59a4f51f42c21bc08b684 /setup.py
parent9e44fb17111d19fea80513ce68dbd15831e4c3dc (diff)
Revert "Support installing into a virtual environment."
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 3 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index e0936fc..16c93b2 100755
--- a/setup.py
+++ b/setup.py
@@ -6,18 +6,9 @@ import os
import site
import sys
-srht_path = os.getenv("SRHT_PATH")
-if not srht_path:
- if hasattr(site, 'getsitepackages'):
- site_packages = site.getsitepackages()[0]
- srht_path = os.path.join(site_packages, "srht")
- else:
- raise Exception("You're running inside a virtual environment. "
- "Due to `virtualenv` limitations, you need to set the "
- "`SRHT_PATH` environment variable to the path of the "
- "`coresrht` module.")
-
-subp = subprocess.run(["make", "SRHT_PATH=" + srht_path], cwd=os.path.dirname(__file__))
+site_packages = site.getsitepackages()[0]
+srht_path = os.path.join(site_packages, "srht")
+subp = subprocess.run(["make", "SRHT_PATH=" + srht_path])
if subp.returncode != 0:
sys.exit(subp.returncode)