summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-04-17 19:20:53 +0200
committerMatthias Beyer <mail@beyermatthias.de>2021-04-17 19:20:53 +0200
commit8dfd21ed430e9407880a5fc640b3351ccf34db5c (patch)
tree993ffecf69680768496ed405af1f4e3665d5eba9 /Cargo.toml
parent056a0728c775e37460ed00791ad503e03a88f3d6 (diff)
Refactor into server-client architecture using protobuf
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 15 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e55ec40..c4369ed 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,7 +5,13 @@ authors = ["Matthias Beyer <mail@beyermatthias.de>"]
edition = "2018"
license = "GPL-2.0"
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[[bin]]
+name = "fss-server"
+path = "src/server.rs"
+
+[[bin]]
+name = "fss"
+path = "src/client.rs"
[dependencies]
anyhow = "1.0.40"
@@ -15,7 +21,15 @@ env_logger = "0.8.3"
getset = "0.1.1"
itertools = "0.10.0"
log = "0.4.14"
+prost = "0.7"
serde = "1.0.125"
tantivy = "0.14"
+tokio = { version = "1.0", features = ["macros", "rt-multi-thread"] }
+tonic = "0.4"
xdg = "2.2.0"
+version = "3.0.0"
+resiter = "0.4"
+
+[build-dependencies]
+tonic-build = "0.4"