summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..01160ab
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,27 @@
+{ pkgs ? (import <nixpkgs> {}) }:
+
+let
+ env = with pkgs.rustChannels.stable; [
+ rust
+ cargo
+ ];
+
+ dependencies = with pkgs; [
+ cmake
+ curl
+ gcc
+ libpsl
+ openssl
+ pkgconfig
+ which
+ zlib
+ dbus
+ libtool
+ ];
+in
+
+pkgs.mkShell rec {
+ buildInputs = env ++ dependencies;
+ LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
+}
+