summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2020-03-25 10:54:06 +0100
committerMatthias Beyer <mail@beyermatthias.de>2020-03-25 10:54:06 +0100
commit42d741c1928264f9b4cb5ec8d990bde4b6feaed3 (patch)
treea2f2f410ca7ade25c8810dfac77f071e01da7b07 /shell.nix
parenteafd3fece3e6828bfba81f2c873a9d08fb2cb8b2 (diff)
Add shell.nix for dev env
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..01160ab
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,27 @@
+{ pkgs ? (import <nixpkgs> {}) }:
+
+let
+ env = with pkgs.rustChannels.stable; [
+ rust
+ cargo
+ ];
+
+ dependencies = with pkgs; [
+ cmake
+ curl
+ gcc
+ libpsl
+ openssl
+ pkgconfig
+ which
+ zlib
+ dbus
+ libtool
+ ];
+in
+
+pkgs.mkShell rec {
+ buildInputs = env ++ dependencies;
+ LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
+}
+