summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-05-22 16:51:07 +0200
committerMatthias Beyer <mail@beyermatthias.de>2021-05-22 16:51:07 +0200
commit4216fe15db7d2bfa43ceef6ac939157353a312c8 (patch)
treeb2a296901f4e9acc607e8b20983b0a2f13738ec0 /Cargo.toml
parentfa655bbe8acae9c7f5d46e977ebea01ac0572327 (diff)
Update ipfs-embed impl
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d557fb9..27e3357 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -20,18 +20,21 @@ edition = "2018"
anyhow = "1"
async-trait = "0.1"
-cid = "0.6"
chrono = "0.4"
+cid = "0.6"
clap-v3 = "3.0.0-beta.1"
daglib = { git = "https://git.sr.ht/~matthiasbeyer/daglib", branch = "master" }
-ipfs-embed = "0.19"
+ipfs-embed = { version = "0.20", features = ["tokio"] }
libipld = "0.11"
libipld-cbor = "0.11"
-libp2p = "0.36"
+libp2p = "*"
libp2p-bitswap = "*"
libp2p-core = "*"
libp2p-gossipsub = "*"
libp2p-ping = "*"
mime = "0.3"
+rand_core = { version = "0.6", features = ["getrandom"] }
+rand_os = "0.2"
+ed25519-dalek = "*"
tokio = { version = "1", features = ["full"] }