summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-04-06 17:06:11 +0200
committerMatthias Beyer <mail@beyermatthias.de>2021-04-06 17:06:11 +0200
commitfa655bbe8acae9c7f5d46e977ebea01ac0572327 (patch)
treeba1617c161214df4e589f931cf205ef383a3e52c /Cargo.toml
parenta70d760dd4d24d2d2963f6e48e3fec027f1e8305 (diff)
Implement first CLI
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 16 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f24ae6f..d557fb9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,15 +17,21 @@ edition = "2018"
[dependencies]
# TODO: Replace with thiserror
-anyhow = "1"
+anyhow = "1"
-async-trait = "0.1"
-cid = "0.6"
-chrono = "0.4"
-daglib = { git = "https://git.sr.ht/~matthiasbeyer/daglib", branch = "master" }
-ipfs-embed = "0.19"
-libipld = "0.11"
-libipld-cbor = "0.11"
-mime = "0.3"
-tokio = { version = "1", features = ["full"] }
+async-trait = "0.1"
+cid = "0.6"
+chrono = "0.4"
+clap-v3 = "3.0.0-beta.1"
+daglib = { git = "https://git.sr.ht/~matthiasbeyer/daglib", branch = "master" }
+ipfs-embed = "0.19"
+libipld = "0.11"
+libipld-cbor = "0.11"
+libp2p = "0.36"
+libp2p-bitswap = "*"
+libp2p-core = "*"
+libp2p-gossipsub = "*"
+libp2p-ping = "*"
+mime = "0.3"
+tokio = { version = "1", features = ["full"] }