summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2022-12-28 16:57:35 +0100
committerMatthias Beyer <mail@beyermatthias.de>2022-12-28 17:13:45 +0100
commit7863c3bcf8c7ca37bfc5652ec92e620968e635e4 (patch)
tree232bcc294e1d442d31a49c060b3b9e14c3f8ed4f /Cargo.toml
parent5cc96a7a9f8a48a13dca4dd6a48dacff27773f3b (diff)
Transform codebase to use thiserror
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 3 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fafb950..a268b24 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,12 +6,10 @@ edition = "2018"
description = "Generic async DAG library"
[dependencies]
-# TODO: Replace with thiserror
-anyhow = "1"
-
async-trait = "0.1"
-futures = "0.3"
-tokio = { version = "1", features = ["full"] }
+futures = "0.3"
+thiserror = "1"
+tokio = { version = "1", features = ["full"] }
[dev-dependencies]
tokio-test = "0.4"