summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRyan Leckey <leckey.ryan@gmail.com>2018-07-02 15:33:13 -0700
committerRyan Leckey <leckey.ryan@gmail.com>2018-07-02 15:33:13 -0700
commitbbc78d85610dec79aa4af4dd360131c7880efb5f (patch)
tree5155483f17de13a06c428cff56d493625e4b9142 /Cargo.toml
parent0226b134bb1871fa4918b52a83073db748bc1b4d (diff)
Clean up Cargo.toml and up float-cmp
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 9 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a87620c..7534ab9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,25 +14,24 @@ license = "MIT/Apache-2.0"
travis-ci = { repository = "mehcode/config-rs" }
[features]
-default = ["toml", "json", "yaml", "hjson","ini"]
+default = ["toml", "json", "yaml", "hjson", "ini"]
json = ["serde_json"]
yaml = ["yaml-rust"]
hjson = ["serde-hjson"]
ini = ["rust-ini"]
-
[dependencies]
lazy_static = "1.0"
-serde = "^1.0.8"
+serde = "1.0.8"
nom = "4.0.0"
-toml = { version = "^0.4.1", optional = true }
-serde_json = { version = "^1.0.2", optional = true }
-yaml-rust = { version = "^0.4", optional = true }
-serde-hjson = { version = "^0.8.1", optional = true }
-rust-ini = { version = "^0.12", optional = true }
+toml = { version = "0.4.1", optional = true }
+serde_json = { version = "1.0.2", optional = true }
+yaml-rust = { version = "0.4", optional = true }
+serde-hjson = { version = "0.8.1", optional = true }
+rust-ini = { version = "0.12", optional = true }
[dev-dependencies]
-serde_derive = "^1.0.8"
-float-cmp = "0.2.3"
+serde_derive = "1.0.8"
+float-cmp = "0.4"
chrono = { version = "0.4", features = ["serde"] }