summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <matthias.beyer@atos.net>2021-08-25 14:13:45 +0200
committerMatthias Beyer <matthias.beyer@atos.net>2021-08-26 12:30:26 +0200
commit78df45ccb9bfbd7a8352c3c8b1f09e4e3ef7d279 (patch)
tree8462e81ce8362eb8e337b5cefea09a025b852ce1 /Cargo.toml
parent9f4765c1db5283ab78b8916bfde2cf18a4299c5c (diff)
Reimplement Repository::load() with parallelism
A quick test showed that the parallel approach here reduced the loading time by approx 10%. Not good, but better than before. Signed-off-by: Matthias Beyer <matthias.beyer@atos.net> Tested-by: Matthias Beyer <matthias.beyer@atos.net>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c8c186b..f70a9e0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -52,6 +52,7 @@ log = "0.4"
parse-display = "0.5"
pom = "3"
ptree = "0.3"
+rayon = "1.5"
regex = "1"
reqwest = { version = "0.11", features = [ "stream" ] }
resiter = "0.4"