summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorEduardo Broto <ebroto@tutanota.com>2019-12-06 23:27:03 +0100
committerEduardo Broto <ebroto@tutanota.com>2019-12-06 23:27:03 +0100
commit2cd4ef5f693b4ff108a7b19ebdce57a52e75b7d6 (patch)
tree5af4df7a70fdba05ad83c60f8d21103c7e17fc75 /Cargo.toml
parent375d4698e0c86cb9c00ce45b88a64a86b30029c4 (diff)
fix(package): update trust-dns and async-trait
This fixes the build problems with the previous latest trust-dns version from crates.io
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 2 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1641909..7899003 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,9 +24,8 @@ chrono = "0.4"
regex = "1.3.1"
lazy_static = "1.4.0"
tokio = { version = "^0.2", features = ["rt-core", "sync"] }
-# temporary fix until https://github.com/bluejekyll/trust-dns/pull/932 is merged
-trust-dns-resolver = { git = "https://github.com/bluejekyll/trust-dns/", branch = "update-tokio-0.2-alpha.2" }
-async-trait = "0.1.19"
+trust-dns-resolver = "0.18.0-alpha.2"
+async-trait = "0.1.21"
[target.'cfg(target_os="linux")'.dependencies]
procfs = "0.7.4"