summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorEduardo Broto <ebroto@tutanota.com>2019-11-20 21:57:33 +0100
committerEduardo Broto <ebroto@tutanota.com>2019-11-30 20:41:12 +0100
commit375d4698e0c86cb9c00ce45b88a64a86b30029c4 (patch)
tree707b74d6551148894b19b3dcb11dbf78395e09b8 /Cargo.toml
parentc5d683078d0bb8727d26db6ce5e5563580d7f9d3 (diff)
feat(dns): resolve hostnames asynchronously
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2b14196..1641909 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,12 +18,15 @@ ipnetwork = "0.15.0"
tui = "0.5"
termion = "1.5"
structopt = "0.3"
-dns-lookup = "1.0.1"
signal-hook = "0.1.10"
failure = "0.1.6"
chrono = "0.4"
regex = "1.3.1"
lazy_static = "1.4.0"
+tokio = { version = "^0.2", features = ["rt-core", "sync"] }
+# temporary fix until https://github.com/bluejekyll/trust-dns/pull/932 is merged
+trust-dns-resolver = { git = "https://github.com/bluejekyll/trust-dns/", branch = "update-tokio-0.2-alpha.2" }
+async-trait = "0.1.19"
[target.'cfg(target_os="linux")'.dependencies]
procfs = "0.7.4"