summaryrefslogtreecommitdiffstats
path: root/atuin-client/Cargo.toml
diff options
context:
space:
mode:
authorConrad Ludgate <conradludgate@gmail.com>2022-10-14 13:33:14 +0100
committerGitHub <noreply@github.com>2022-10-14 13:33:14 +0100
commit990040e150ed1ec240a45f121fe8e110d38b048a (patch)
tree782e1eef0ac2f705002b5a36131e783f96f69498 /atuin-client/Cargo.toml
parentcd8e88af6873fdefd9a760ec96eae6878f61057c (diff)
rollup of 5 dependency commits (#562)
* Bump sha2 from 0.10.5 to 0.10.6 Bumps [sha2](https://github.com/RustCrypto/hashes) from 0.10.5 to 0.10.6. - [Release notes](https://github.com/RustCrypto/hashes/releases) - [Commits](https://github.com/RustCrypto/hashes/compare/sha2-v0.10.5...sha2-v0.10.6) --- updated-dependencies: - dependency-name: sha2 dependency-type: direct:production update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <support@github.com> * Bump uuid from 1.1.2 to 1.2.1 Bumps [uuid](https://github.com/uuid-rs/uuid) from 1.1.2 to 1.2.1. - [Release notes](https://github.com/uuid-rs/uuid/releases) - [Commits](https://github.com/uuid-rs/uuid/compare/1.1.2...1.2.1) --- updated-dependencies: - dependency-name: uuid dependency-type: direct:production update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com> * Bump serde_json from 1.0.85 to 1.0.86 Bumps [serde_json](https://github.com/serde-rs/json) from 1.0.85 to 1.0.86. - [Release notes](https://github.com/serde-rs/json/releases) - [Commits](https://github.com/serde-rs/json/compare/v1.0.85...v1.0.86) --- updated-dependencies: - dependency-name: serde_json dependency-type: direct:production update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <support@github.com> * Bump itertools from 0.10.4 to 0.10.5 Bumps [itertools](https://github.com/rust-itertools/itertools) from 0.10.4 to 0.10.5. - [Release notes](https://github.com/rust-itertools/itertools/releases) - [Changelog](https://github.com/rust-itertools/itertools/blob/master/CHANGELOG.md) - [Commits](https://github.com/rust-itertools/itertools/commits) --- updated-dependencies: - dependency-name: itertools dependency-type: direct:production update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <support@github.com> * Bump serde from 1.0.144 to 1.0.145 Bumps [serde](https://github.com/serde-rs/serde) from 1.0.144 to 1.0.145. - [Release notes](https://github.com/serde-rs/serde/releases) - [Commits](https://github.com/serde-rs/serde/compare/v1.0.144...v1.0.145) --- updated-dependencies: - dependency-name: serde dependency-type: direct:production update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <support@github.com> Signed-off-by: dependabot[bot] <support@github.com> Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Diffstat (limited to 'atuin-client/Cargo.toml')
-rw-r--r--atuin-client/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/atuin-client/Cargo.toml b/atuin-client/Cargo.toml
index 4df86006..f693d4cc 100644
--- a/atuin-client/Cargo.toml
+++ b/atuin-client/Cargo.toml
@@ -29,15 +29,15 @@ log = "0.4"
chrono = { version = "0.4", features = ["serde"] }
eyre = "0.6"
directories = "4"
-uuid = { version = "1.0", features = ["v4"] }
+uuid = { version = "1.2", features = ["v4"] }
whoami = "1.1.2"
chrono-english = "0.1.4"
config = { version = "0.13", default-features = false, features = ["toml"] }
-serde = { version = "1.0.137", features = ["derive"] }
-serde_json = "1.0.81"
+serde = { version = "1.0.145", features = ["derive"] }
+serde_json = "1.0.86"
parse_duration = "2.1.1"
async-trait = "0.1.49"
-itertools = "0.10.3"
+itertools = "0.10.5"
shellexpand = "2"
sqlx = { version = "0.6", features = [
"runtime-tokio-rustls",