summaryrefslogtreecommitdiffstats
path: root/zellij-client/Cargo.toml
diff options
context:
space:
mode:
authorAram Drevekenin <aram@poor.dev>2021-06-30 11:27:35 +0200
committerGitHub <noreply@github.com>2021-06-30 11:27:35 +0200
commited4fd2a8e77df304539ca7f445a78039028eaa8a (patch)
treeae48b03370b11f3f0987676584724463ac83460d /zellij-client/Cargo.toml
parent974edc2c98abf22b29598480c41f2505edef4dd1 (diff)
chore(tests): move all integration tests to be either unit or e2e tests - remove old testing infra (#589)
* tests(integration): move basic integration tests to be unit tests * fix(tests): silently fail threadbus for tests * tests(unit): move compatibility tests to become unit tests for grid * tests(unit): move close_pane tests to become unit tests for grid * tests(e2e): move basic layout test to e2e * tests(unit): move move_focus tests to be unit tests * tests(unit): move resize_down tests to be unit tests * tests(unit): move resize_left tests to be unit tests * tests(unit): move resize_right tests to be unit tests * tests(unit): move resize_up tests to be unit tests * tests(infra): remove unused infra * style(fmt): make rustfmt happy * debug * debug * debug * debug * chore(test): shift volume mounting around because github actions is a special child
Diffstat (limited to 'zellij-client/Cargo.toml')
-rw-r--r--zellij-client/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/zellij-client/Cargo.toml b/zellij-client/Cargo.toml
index 726bd3a29..9b04104b3 100644
--- a/zellij-client/Cargo.toml
+++ b/zellij-client/Cargo.toml
@@ -12,5 +12,8 @@ license = "MIT"
termbg = "0.2.3"
zellij-utils = { path = "../zellij-utils/", version = "0.14.0" }
+[dev-dependencies]
+insta = "1.6.0"
+
[features]
test = ["zellij-utils/test"]