summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorThomas Linford <tlinford@users.noreply.github.com>2023-05-03 21:16:38 +0200
committerGitHub <noreply@github.com>2023-05-03 21:16:38 +0200
commitf598ca373829c99c6e2b2c6064047ed07c139ff7 (patch)
tree3f409b9218d9eaec5f7ce087408f75c29914fb07 /Cargo.toml
parentecd63a100b9d927d78c64cda73bae5ec16cac419 (diff)
improve build/ci times (#2396)
- avoid building all workspace crates with `cargo x build` (only plugins and main binary) - only set the target triple in tests for plugins - add new profile for `cargo x run` to build with optimized dependencies => FAST plugins when developing (thanks [Bevy Book](https://bevyengine.org/learn/book/getting-started/setup/#compile-with-performance-optimizations) for the idea) - use https://github.com/Swatinem/rust-cache to avoid rebuilding dependencies every time in ci - split `Build & Test` job into two so they run in parallel - hopefully improve the flaky tests situation, this also makes the e2e tests run much faster (some tests produced correct snapshots but had some logic errors causing them to loop for much longer than necessary). Add some output to the tests so it is easier to see if something goes wrong. - remove verbose build output from e2e test build
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 484bacf2c..f73af05a1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,6 +45,12 @@ members = [
".",
]
+[profile.dev-opt]
+inherits = "dev"
+
+[profile.dev-opt.package."*"]
+opt-level = 3
+
[profile.release]
lto = true
strip = true