summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJae-Heon Ji <32578710+jaeheonji@users.noreply.github.com>2022-02-27 23:06:43 +0900
committerGitHub <noreply@github.com>2022-02-27 23:06:43 +0900
commitc7913c362c3ff7156965462995ba871f8b3e3af6 (patch)
tree0cbf6c2f15c1dcc04feacd3ce5b530c367c8ed7e /Cargo.toml
parentb7e4d902f2e1aa20cf37954541bb1b1cbf6afd49 (diff)
feat: add `cargo-binstall` method (#1129)
* feat: add cargo-binstall method * fix: update archive format type
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 66724b6f9..01d3748eb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -59,5 +59,10 @@ assets = [
["assets/completions/_zellij", "usr/share/zsh/vendor-completions/_zellij", "644"],
]
+[package.metadata.binstall]
+pkg-url = "{ repo }/releases/download/v{ version }/{ name }-{ target }.tar.gz"
+bin-dir = "{ bin }{ binary-ext }"
+pkg-fmt = "tgz"
+
[features]
disable_automatic_asset_installation = []