summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorm-lima <m-lima@users.noreply.github.com>2023-02-07 17:55:37 +0100
committerGitHub <noreply@github.com>2023-02-07 17:55:37 +0100
commit5b3e1ecacd31bf554b59885a01bf4701874b9063 (patch)
treed76a470e155f84183f5cdb5fcd7ca0c1153f924f /Cargo.toml
parente3981283a99e866faefa53cd7c06040ea99cac39 (diff)
chore(development): use singlepass in debug mode (#2134)
* Add new feature flags * Use singlepass in debug mode * Use Cow to avoid unnecessary copies - Instead of removing and reinserting into the memory cache, use Cow to model both owned an borrowed data - Log at debug-level the time to compile/load a wasm module - A little clippy drive-by on touched files * Satisfy the assumption from zellij-utils/src/consts.rs for target-dir * Allow forcing cranlift in debug mode * Remove deprecated comments * PR comment: typo * Remove extras
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index af10e36cb..dbe216526 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -73,3 +73,4 @@ pkg-fmt = "tgz"
default = [ "zellij-utils/plugins_from_target" ]
disable_automatic_asset_installation = [ "zellij-utils/disable_automatic_asset_installation" ]
unstable = [ "zellij-client/unstable", "zellij-utils/unstable" ]
+force_cranelift = [ "zellij-server/force_cranelift" ]