summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorhar7an <99636919+har7an@users.noreply.github.com>2022-11-09 08:40:02 +0000
committerGitHub <noreply@github.com>2022-11-09 08:40:02 +0000
commit5975af6e42f512700101b3ca4ad6cbe5ca416117 (patch)
treee18eac6b0671c20a1d045d2e4c7b497280d9dc62 /Cargo.toml
parent48bc2281c74732559c74c2d678895cdfeec08126 (diff)
cargo: Don't strip release binary (#1916)
* cargo: Don't strip release binary because the lack of debug symbols makes the panic backtrace completely useless. It will show a long list of unknown locations then. Except for a minor space saving of 3-4 MB, debug symbols don't have any negative side-effects for our application that we're aware of. * changelog: Add PR #1916 Don't strip debug symbols from release binaries so the backtraces contain the function names involved. * cargo: Explicitly keep debug symbols and add a comment explaining why.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fb16b35de..428657a52 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,7 +45,8 @@ members = [
[profile.release]
lto = true
-strip = true
+# Keep debug symbols so we see function names in backtraces
+strip = false
[package.metadata.deb]
depends = "$auto"