summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index f6e54b30b0..e092f686a6 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1173,13 +1173,17 @@ if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
-e 's/-W[[^ ]]*//g' \
-e 's/-D_FORTIFY_SOURCE=.//g'`
dnl Remove "-lc", it breaks on FreeBSD when using "-pthread".
+ dnl Remove -specs=<file-path>, the hardened flags cause relocation errors
perllibs=`cd $srcdir; $vi_cv_path_perl -MExtUtils::Embed -e 'ldopts' | \
sed -e '/Warning/d' -e '/Note (probably harmless)/d' \
+ -e 's/-specs=[[^ ]*]//g' \
-e 's/-bE:perl.exp//' -e 's/-lc //'`
dnl Don't add perl lib to $LIBS: if it's not in LD_LIBRARY_PATH
dnl a test in configure may fail because of that.
+ dnl Remove -specs=<file-path>, the hardened flags cause relocation errors
perlldflags=`cd $srcdir; $vi_cv_path_perl -MExtUtils::Embed \
- -e 'ccdlflags' | sed -e 's/-bE:perl.exp//'`
+ -e 'ccdlflags' | sed -e 's/-bE:perl.exp//' \
+ -e 's/-specs=[[^ ]*]//g' `
dnl check that compiling a simple program still works with the flags
dnl added for Perl.