summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 946fe52ffe..29cd926b56 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4497,6 +4497,12 @@ if test "$enable_nls" = "yes"; then
AC_SUBST(MAKEMO)
dnl this was added in GNU gettext 0.10.36
AC_CHECK_FUNCS(bind_textdomain_codeset)
+ AC_MSG_CHECKING([for dgettext])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM(
+ [#include <libintl.h>],
+ [dgettext("Test", "Test");])],
+ AC_MSG_RESULT([yes]); AC_DEFINE(HAVE_DGETTEXT),
+ AC_MSG_RESULT([no]))
dnl _nl_msg_cat_cntr is required for GNU gettext
AC_MSG_CHECKING([for _nl_msg_cat_cntr])
AC_LINK_IFELSE([AC_LANG_PROGRAM(