summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 010cc8f09c..4b6794a29e 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4467,6 +4467,10 @@ else
AC_MSG_RESULT(no)
fi
+dnl $LDFLAGS is passed to glibtool in libvterm, it doesn't like a space
+dnl between "-L" and the path that follows.
+LDFLAGS=`echo "$LDFLAGS" | sed -e 's/-L /-L/g'`
+
dnl link.sh tries to avoid overlinking in a hackish way.
dnl At least GNU ld supports --as-needed which provides the same functionality
dnl at linker level. Let's use it.