summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 6813d76857..d753ffe6e5 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4,7 +4,8 @@ dnl Process this file with autoconf 2.69 to produce "configure".
dnl This should also work with other versions of autoconf, but 2.70 and later
dnl generate lots of hard to fix "obsolete" warnings.
-AC_INIT(vim.h)
+AC_INIT
+AC_CONFIG_SRCDIR([vim.h])
AC_CONFIG_HEADERS(auto/config.h:config.h.in)
dnl Being able to run configure means the system is Unix (compatible).
@@ -14,9 +15,8 @@ AC_PROG_MAKE_SET
dnl Checks for programs.
AC_PROG_CC_C99 dnl required by almost everything
AC_PROG_CPP dnl required by header file checks
-AC_PROGRAM_EGREP dnl required by AC_EGREP_CPP
+AC_PROG_EGREP dnl required by AC_EGREP_CPP
AC_PROG_FGREP dnl finds working grep -F
-AC_ISC_POSIX dnl required by AC_C_CROSS
AC_PROG_AWK dnl required for "make html" in ../doc
dnl Don't strip if we don't have it
@@ -3354,7 +3354,8 @@ AC_TYPE_SIZE_T
AC_TYPE_UID_T
AC_TYPE_UINT32_T
-AC_HEADER_TIME
+AC_CHECK_HEADERS_ONCE([sys/time.h])
+
AC_CHECK_TYPE(ino_t, long)
AC_CHECK_TYPE(dev_t, unsigned)
AC_C_BIGENDIAN(,,,)
@@ -3605,8 +3606,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([
AC_DEFINE(SYS_SELECT_WITH_SYS_TIME),
AC_MSG_RESULT(no))
-dnl AC_DECL_SYS_SIGLIST
-
dnl Checks for pty.c (copied from screen) ==========================
AC_MSG_CHECKING(for /dev/ptc)
if test -r /dev/ptc; then