summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac26
1 files changed, 1 insertions, 25 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 76eb56327c..b688032d00 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3952,32 +3952,8 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([
AC_MSG_RESULT(yes); AC_DEFINE(HAVE_NL_LANGINFO_CODESET),
AC_MSG_RESULT(no))
-dnl Need various functions for floating point support. Only enable
-dnl floating point when they are all present.
+dnl Floating point support may require the "m" library
AC_CHECK_LIB(m, strtod)
-AC_MSG_CHECKING([for strtod() and other floating point functions])
-AC_LINK_IFELSE([AC_LANG_PROGRAM([
-#ifdef HAVE_MATH_H
-# include <math.h>
-#endif
-#if STDC_HEADERS
-# include <stdlib.h>
-# include <stddef.h>
-#endif
-], [char *s; double d;
- d = strtod("1.1", &s);
- d = fabs(1.11);
- d = ceil(1.11);
- d = floor(1.11);
- d = log10(1.11);
- d = pow(1.11, 2.22);
- d = sqrt(1.11);
- d = sin(1.11);
- d = cos(1.11);
- d = atan(1.11);
- ])],
- AC_MSG_RESULT(yes); AC_DEFINE(HAVE_FLOAT_FUNCS),
- AC_MSG_RESULT(no))
dnl isinf() and isnan() need to include header files and may need -lm.
AC_MSG_CHECKING([for isinf()])