summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index b5f217ca1f..86f70f581c 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -567,6 +567,16 @@ else
AC_MSG_RESULT(yes)
fi
+AC_MSG_CHECKING([diff feature])
+if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ AC_MSG_RESULT([disabled in $features version])
+else
+ AC_MSG_RESULT(enabled)
+ AC_DEFINE(FEAT_DIFF)
+ XDIFF_OBJS_USED="\$(XDIFF_OBJS)"
+ AC_SUBST(XDIFF_OBJS_USED)
+fi
+
dnl Check for Lua feature.
AC_MSG_CHECKING(--enable-luainterp argument)
AC_ARG_ENABLE(luainterp,