summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2010-07-24 15:19:11 +0200
committerBram Moolenaar <Bram@vim.org>2010-07-24 15:19:11 +0200
commit2a7e2a62543126d75525d861c3417ac9bb209159 (patch)
tree594726962a36c392e5870437d53534b8a3144a49 /src/configure.in
parentca8c9867c2e6112f17975d840b9551cd91287eb6 (diff)
Specify library to load for Python more precisely. (James Vega)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/configure.in b/src/configure.in
index 0492eb08dd..18c7ff1825 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -822,6 +822,7 @@ __:
@echo "python_LIBS='$(LIBS)'"
@echo "python_SYSLIBS='$(SYSLIBS)'"
@echo "python_LINKFORSHARED='$(LINKFORSHARED)'"
+ @echo "python_INSTSONAME='$(INSTSONAME)'"
eof
dnl -- delete the lines from make about Entering/Leaving directory
eval "`cd ${PYTHON_CONFDIR} && make -f "${tmp_mkf}" __ | sed '/ directory /d'`"
@@ -1001,6 +1002,7 @@ __:
@echo "python3_LIBS='$(LIBS)'"
@echo "python3_SYSLIBS='$(SYSLIBS)'"
@echo "python3_LINKFORSHARED='$(LINKFORSHARED)'"
+ @echo "python3_INSTSONAME='$(INSTSONAME)'"
eof
dnl -- delete the lines from make about Entering/Leaving directory
eval "`cd ${PYTHON3_CONFDIR} && make -f "${tmp_mkf}" __ | sed '/ directory /d'`"
@@ -1096,11 +1098,11 @@ if test "$python_ok" = yes && test "$python3_ok" = yes; then
AC_DEFINE(DYNAMIC_PYTHON3)
PYTHON_SRC="if_python.c"
PYTHON_OBJ="objects/if_python.o"
- PYTHON_CFLAGS="$PYTHON_CFLAGS -DDYNAMIC_PYTHON_DLL=\\\"libpython${vi_cv_var_python_version}.so\\\""
+ PYTHON_CFLAGS="$PYTHON_CFLAGS -DDYNAMIC_PYTHON_DLL=\\\"${python_INSTSONAME}\\\""
PYTHON_LIBS=
PYTHON3_SRC="if_python3.c"
PYTHON3_OBJ="objects/if_python3.o"
- PYTHON3_CFLAGS="$PYTHON3_CFLAGS -DDYNAMIC_PYTHON3_DLL=\\\"libpython${vi_cv_var_python3_version}.so\\\""
+ PYTHON3_CFLAGS="$PYTHON3_CFLAGS -DDYNAMIC_PYTHON3_DLL=\\\"${python3_INSTSONAME}\\\""
PYTHON3_LIBS=
fi