summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2011-09-02 12:27:25 +0200
committerBram Moolenaar <Bram@vim.org>2011-09-02 12:27:25 +0200
commit6fabcbe26002fd75f87c6775239b0e51e1169d68 (patch)
tree1c6fe3358becce900864de6cdcaa323ae94aadc6 /src/configure.in
parent39fc42ef9d3d255d775198f47f0ba53caa078441 (diff)
updated for version 7.3.291v7.3.291
Problem: Configure doesn't work properly with Python3. Solution: Put -ldl before $LDFLAGS. Add PY3_NO_RTLD_GLOBAL. (Roland Puntaier)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/configure.in b/src/configure.in
index 52e0600c89..b09aa220e9 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1161,7 +1161,8 @@ if test "$python_ok" = yes && test "$python3_ok" = yes; then
cflags_save=$CFLAGS
CFLAGS="$CFLAGS $PYTHON_CFLAGS"
ldflags_save=$LDFLAGS
- LDFLAGS="$LDFLAGS -ldl"
+ dnl -ldl must go first to make this work on Archlinux (Roland Puntaier)
+ LDFLAGS="-ldl $LDFLAGS"
AC_RUN_IFELSE([
#include <dlfcn.h>
/* If this program fails, then RTLD_GLOBAL is needed.
@@ -1205,7 +1206,8 @@ if test "$python_ok" = yes && test "$python3_ok" = yes; then
cflags_save=$CFLAGS
CFLAGS="$CFLAGS $PYTHON3_CFLAGS"
ldflags_save=$LDFLAGS
- LDFLAGS="$LDFLAGS -ldl"
+ dnl -ldl must go first to make this work on Archlinux (Roland Puntaier)
+ LDFLAGS="-ldl $LDFLAGS"
AC_RUN_IFELSE([
#include <dlfcn.h>
#include <wchar.h>