summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2013-08-07 15:22:23 +0200
committerBram Moolenaar <Bram@vim.org>2013-08-07 15:22:23 +0200
commit026a445c4034ce3f489d582c45e2cf49bd77322e (patch)
tree98bf5236cbfeac43bb0682c2b4c087f5ccacc584 /src/configure.in
parent01c458e4383002519b542c95371153eb4b83789e (diff)
updated for version 7.4b.016v7.4b.016
Problem: Ruby detection fails on Fedora 19. Solution: Use one way to get the Ruby version. (Michael Henry)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index c20b198da8..ed30bedf86 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1659,6 +1659,9 @@ if test "$enable_rubyinterp" = "yes" -o "$enable_rubyinterp" = "dynamic"; then
RUBY_CFLAGS="$RUBY_CFLAGS -I$rubyhdrdir/$rubyarch"
fi
rubyversion=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig::CONFIG[['ruby_version']].gsub(/\./, '')[[0,2]]"`
+ if test "X$rubyversion" = "X"; then
+ rubyversion=`$vi_cv_path_ruby -e "print ((VERSION rescue RUBY_VERSION)).gsub(/\./, '')[[0,2]]"`
+ fi
RUBY_CFLAGS="$RUBY_CFLAGS -DRUBY_VERSION=$rubyversion"
rubylibs=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig::CONFIG[['LIBS']]"`
if test "X$rubylibs" != "X"; then