summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2014-03-27 17:19:09 +0100
committerBram Moolenaar <Bram@vim.org>2014-03-27 17:19:09 +0100
commita6fd37be4fa01cef4bc4368f8fa814d9c6d084fd (patch)
treec8db3b1d71a009ae2628587abc0d666ae4ec61a0 /src/configure.in
parent158864120d3ee8baa2b5c9c2cb15bd5c5ea5731b (diff)
updated for version 7.4.222v7.4.222
Problem: The Ruby directory is constructed from parts. Solution: Use 'rubyarchhdrdir' if it exists. (James McCoy)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/configure.in b/src/configure.in
index cf693505a0..ac6eb45090 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1692,9 +1692,9 @@ if test "$enable_rubyinterp" = "yes" -o "$enable_rubyinterp" = "dynamic"; then
if test "X$rubyhdrdir" != "X"; then
AC_MSG_RESULT($rubyhdrdir)
RUBY_CFLAGS="-I$rubyhdrdir"
- rubyarch=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig::CONFIG[['arch']]"`
- if test -d "$rubyhdrdir/$rubyarch"; then
- RUBY_CFLAGS="$RUBY_CFLAGS -I$rubyhdrdir/$rubyarch"
+ rubyarchdir=`$vi_cv_path_ruby -r rbconfig -e "print ($ruby_rbconfig::CONFIG.has_key? 'rubyarchhdrdir') ? $ruby_rbconfig::CONFIG[['rubyarchhdrdir']] : '$rubyhdrdir/'+$ruby_rbconfig::CONFIG[['arch']]"`
+ if test -d "$rubyarchdir"; then
+ RUBY_CFLAGS="$RUBY_CFLAGS -I$rubyarchdir"
fi
rubyversion=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig::CONFIG[['ruby_version']].gsub(/\./, '')[[0,2]]"`
if test "X$rubyversion" = "X"; then