summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2006-03-18 21:40:56 +0000
committerBram Moolenaar <Bram@vim.org>2006-03-18 21:40:56 +0000
commit97b2ad35425fd589c4ff816d1f1161f2f7f6a93d (patch)
treea0fed79e1bd28b00c32554c62110903d49ac9b20 /src/configure.in
parent658b74a7360cff23939dbf5075b8e18e38c77a81 (diff)
updated for version 7.0228
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index 3412b95d05..90eb33b8a6 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1478,6 +1478,17 @@ AC_DEFUN([GNOME_INIT_HOOK],
GNOME_LIBS=`$PKG_CONFIG --libs-only-l libgnomeui-2.0`
GNOME_LIBDIR=`$PKG_CONFIG --libs-only-L libgnomeui-2.0`
GNOME_INCLUDEDIR=`$PKG_CONFIG --cflags libgnomeui-2.0`
+
+ dnl On FreeBSD we need -pthread but pkg-config doesn't include it.
+ dnl This might not be the right way but it works for me...
+ AC_MSG_CHECKING(for FreeBSD)
+ if test "`(uname) 2>/dev/null`" = FreeBSD; then
+ AC_MSG_RESULT(yes, adding -pthread)
+ GNOME_INCLUDEDIR="$GNOME_INCLUDEDIR -D_THREAD_SAFE"
+ GNOME_LIBS="$GNOME_LIBS -pthread"
+ else
+ AC_MSG_RESULT(no)
+ fi
$1
else
AC_MSG_RESULT(not found)