summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2014-04-02 14:05:38 +0200
committerBram Moolenaar <Bram@vim.org>2014-04-02 14:05:38 +0200
commit5bd32f47ec5121a5485d180add1dacb73472e4b2 (patch)
treef779d9e3e80717a5a8f06a154eaa332ab2452618 /src/configure.in
parent6716d9af113a5c4bcc7fdf8fd24f3d633db386c7 (diff)
updated for version 7.4.238v7.4.238
Problem: Vim does not support the smack library. Solution: Add smack support (Jose Bollo)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in39
1 files changed, 30 insertions, 9 deletions
diff --git a/src/configure.in b/src/configure.in
index 37c5ff8e8f..22ff9fd8ac 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -387,20 +387,41 @@ fi
AC_SUBST(QUOTESED)
-dnl Link with -lselinux for SELinux stuff; if not found
-AC_MSG_CHECKING(--disable-selinux argument)
-AC_ARG_ENABLE(selinux,
- [ --disable-selinux Don't check for SELinux support.],
- , enable_selinux="yes")
-if test "$enable_selinux" = "yes"; then
+dnl Link with -lsmack for Smack stuff; if not found
+AC_MSG_CHECKING(--disable-smack argument)
+AC_ARG_ENABLE(smack,
+ [ --disable-smack Do not check for Smack support.],
+ , enable_smack="yes")
+if test "$enable_smack" = "yes"; then
+ AC_CHECK_HEADER([linux/xattr.h], true, enable_smack="no")
+fi
+if test "$enable_smack" = "yes"; then
AC_MSG_RESULT(no)
- AC_CHECK_LIB(selinux, is_selinux_enabled,
- [LIBS="$LIBS -lselinux"
- AC_DEFINE(HAVE_SELINUX)])
+ AC_CHECK_LIB(attr, llistxattr,
+ [LIBS="$LIBS -lattr"
+ found_smack="yes"
+ AC_DEFINE(HAVE_SMACK)])
else
AC_MSG_RESULT(yes)
fi
+dnl When smack was found don't search for SELinux
+if test "x$found_smack" = "x"; then
+ dnl Link with -lselinux for SELinux stuff; if not found
+ AC_MSG_CHECKING(--disable-selinux argument)
+ AC_ARG_ENABLE(selinux,
+ [ --disable-selinux Do not check for SELinux support.],
+ , enable_selinux="yes")
+ if test "$enable_selinux" = "yes"; then
+ AC_MSG_RESULT(no)
+ AC_CHECK_LIB(selinux, is_selinux_enabled,
+ [LIBS="$LIBS -lselinux"
+ AC_DEFINE(HAVE_SELINUX)])
+ else
+ AC_MSG_RESULT(yes)
+ fi
+fi
+
dnl Check user requested features.
AC_MSG_CHECKING(--with-features argument)