summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2014-04-05 12:02:25 +0200
committerBram Moolenaar <Bram@vim.org>2014-04-05 12:02:25 +0200
commit4ed89cdf41cf3d509fd30e6f7c577a7c090679a9 (patch)
tree1f486635fd389d67ef1b36467f42dc71e21525f3 /src/configure.in
parent21e854e5ce08ad419441136b1698d535ff818a72 (diff)
updated for version 7.4.246v7.4.246
Problem: Configure message for detecting smack are out of sequence. Solution: Put the messages in the right place. (Kazunobu Kuriyama)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/configure.in b/src/configure.in
index 22ff9fd8ac..b22b9ea5cd 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -393,16 +393,16 @@ AC_ARG_ENABLE(smack,
[ --disable-smack Do not check for Smack support.],
, enable_smack="yes")
if test "$enable_smack" = "yes"; then
+ AC_MSG_RESULT(no)
AC_CHECK_HEADER([linux/xattr.h], true, enable_smack="no")
+else
+ AC_MSG_RESULT(yes)
fi
if test "$enable_smack" = "yes"; then
- AC_MSG_RESULT(no)
AC_CHECK_LIB(attr, llistxattr,
[LIBS="$LIBS -lattr"
found_smack="yes"
AC_DEFINE(HAVE_SMACK)])
-else
- AC_MSG_RESULT(yes)
fi
dnl When smack was found don't search for SELinux