summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2016-04-21 18:20:11 +0200
committerBram Moolenaar <Bram@vim.org>2016-04-21 18:20:11 +0200
commit4adfaabfe7e07da9546b45130cad0d266ba48611 (patch)
tree2902951bbe4ab52530507f13df36c94ce9cd4bb6 /src/configure.in
parent0c1ff16b5467f97ce08134fdbc8198127bbe492a (diff)
patch 7.4.1767v7.4.1767
Problem: When installing Vim on a GTK system the icon cache is not updated. Solution: Update the GTK icon cache when possible. (Kazunobu Kuriyama)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index 0a8c95bc6e..279ed47227 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -2688,10 +2688,42 @@ if test "x$GUITYPE" = "xGTK"; then
else
AC_MSG_RESULT([cannot obtain from pkg_config.])
fi
+
+ AC_MSG_CHECKING([--disable-icon-cache-update argument])
+ AC_ARG_ENABLE(icon_cache_update,
+ [ --disable-icon-cache-update update disabled],
+ [],
+ [enable_icon_cache_update="yes"])
+ if test "$enable_icon_cache_update" = "yes"; then
+ AC_MSG_RESULT([not set])
+ AC_PATH_PROG(GTK_UPDATE_ICON_CACHE,[gtk-update-icon-cache],no)
+ if test "x$GTK_UPDATE_ICON_CACHE" = "xno" ; then
+ AC_MSG_RESULT([not found in PATH.])
+ fi
+ else
+ AC_MSG_RESULT([update disabled])
+ fi
+
+ AC_MSG_CHECKING([--disable-desktop-database-update argument])
+ AC_ARG_ENABLE(desktop_database_update,
+ [ --disable-desktop-database-update update disabled],
+ [],
+ [enable_desktop_database_update="yes"])
+ if test "$enable_desktop_database_update" = "yes"; then
+ AC_MSG_RESULT([not set])
+ AC_PATH_PROG(UPDATE_DESKTOP_DATABASE,[update-desktop-database],no)
+ if test "x$UPDATE_DESKTOP_DATABASE" = "xno" ; then
+ AC_MSG_RESULT([not found in PATH.])
+ fi
+ else
+ AC_MSG_RESULT([update disabled])
+ fi
fi
AC_SUBST(GLIB_COMPILE_RESOURCES)
AC_SUBST(GRESOURCE_SRC)
AC_SUBST(GRESOURCE_OBJ)
+AC_SUBST(GTK_UPDATE_ICON_CACHE)
+AC_SUBST(UPDATE_DESKTOP_DATABASE)
dnl Check for Motif include files location.
dnl The LAST one found is used, this makes the highest version to be used,