summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2016-01-31 14:36:58 +0100
committerBram Moolenaar <Bram@vim.org>2016-01-31 14:36:58 +0100
commit3c124e3ac81521ae1e7e4a9cb9597ab754b92429 (patch)
tree7452d30962178a3e88d5ae383b1afc8fd0742d9f /src/configure.in
parentfa399af7ece091203bd70ebcf955bf07a820beff (diff)
patch 7.4.1221v7.4.1221
Problem: Including netbeans and channel support in small and tiny builds. Build fails with some interfaces. Solution: Only include these features in small build and above. Let configure fail if trying to enable an interface that won't build.
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in21
1 files changed, 19 insertions, 2 deletions
diff --git a/src/configure.in b/src/configure.in
index 08ba5623e3..467ea6bc52 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -490,6 +490,10 @@ AC_ARG_ENABLE(luainterp,
AC_MSG_RESULT($enable_luainterp)
if test "$enable_luainterp" = "yes" -o "$enable_luainterp" = "dynamic"; then
+ if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ AC_MSG_ERROR([cannot use Lua with tiny or small features])
+ fi
+
dnl -- find the lua executable
AC_SUBST(vi_cv_path_lua)
@@ -950,6 +954,9 @@ AC_ARG_ENABLE(perlinterp,
[enable_perlinterp="no"])
AC_MSG_RESULT($enable_perlinterp)
if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
+ if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ AC_MSG_ERROR([cannot use Perl with tiny or small features])
+ fi
AC_SUBST(vi_cv_path_perl)
AC_PATH_PROG(vi_cv_path_perl, perl)
if test "X$vi_cv_path_perl" != "X"; then
@@ -1937,7 +1944,12 @@ AC_ARG_ENABLE(netbeans,
[ --disable-netbeans Disable NetBeans integration support.],
, [enable_netbeans="yes"])
if test "$enable_netbeans" = "yes"; then
- AC_MSG_RESULT(no)
+ if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ AC_MSG_RESULT([cannot use NetBeans with tiny or small features])
+ enable_netbeans="no"
+ else
+ AC_MSG_RESULT(no)
+ fi
else
AC_MSG_RESULT(yes)
fi
@@ -1947,7 +1959,12 @@ AC_ARG_ENABLE(channel,
[ --disable-channel Disable process communication support.],
, [enable_channel="yes"])
if test "$enable_channel" = "yes"; then
- AC_MSG_RESULT(no)
+ if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ AC_MSG_RESULT([cannot use channels with tiny or small features])
+ enable_channel="no"
+ else
+ AC_MSG_RESULT(no)
+ fi
else
if test "$enable_netbeans" = "yes"; then
AC_MSG_RESULT([yes, netbeans also disabled])