summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2008-07-24 14:24:48 +0000
committerBram Moolenaar <Bram@vim.org>2008-07-24 14:24:48 +0000
commit01dd60cb9156c4a361558995323c018d2ead7ad1 (patch)
tree291fbef29826e7a1ae970a557cf2aae9ecdab7c6 /src/configure.in
parent688e5f7ee7e9384494e9c16ae48c512980c54e4f (diff)
updated for version 7.2b-014v7.2b.014
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/configure.in b/src/configure.in
index 49acc196b9..8eaddcbd0b 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -678,8 +678,9 @@ if test "$enable_pythoninterp" = "yes"; then
dnl see what the interpreter is built from
AC_CACHE_VAL(vi_cv_path_python_plibs,
[
- tmp_mkf="/tmp/Makefile-conf$$"
- cat ${PYTHON_CONFDIR}/Makefile - <<'eof' >${tmp_mkf}
+ pwd=`pwd`
+ tmp_mkf="$pwd/config-PyMake$$"
+ cat -- "${PYTHON_CONFDIR}/Makefile" - <<'eof' >"${tmp_mkf}"
__:
@echo "python_MODLIBS='$(MODLIBS)'"
@echo "python_LIBS='$(LIBS)'"
@@ -687,8 +688,8 @@ __:
@echo "python_LINKFORSHARED='$(LINKFORSHARED)'"
eof
dnl -- delete the lines from make about Entering/Leaving directory
- eval "`cd ${PYTHON_CONFDIR} && make -f ${tmp_mkf} __ | sed '/ directory /d'`"
- rm -f ${tmp_mkf}
+ eval "`cd ${PYTHON_CONFDIR} && make -f "${tmp_mkf}" __ | sed '/ directory /d'`"
+ rm -f -- "${tmp_mkf}"
if test "x$MACOSX" = "xyes" && ${vi_cv_path_python} -c \
"import sys; sys.exit(${vi_cv_var_python_version} < 2.3)"; then
vi_cv_path_python_plibs="-framework Python"