summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2016-01-24 20:36:41 +0100
committerBram Moolenaar <Bram@vim.org>2016-01-24 20:36:41 +0100
commite0874f8cbcddfcf9965a85ba35199964efb1d01a (patch)
tree02cba2d1d135a96e3983f0676bb11da770ab0426 /src/configure.in
parent705ada1aff27ecd9c47c690df817d043c2ceb5e2 (diff)
patch 7.4.1169v7.4.1169
Problem: The socket I/O is intertwined with the netbeans code. Solution: Start refactoring the netbeans communication to split off the socket I/O. Add the +channel feature.
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in33
1 files changed, 29 insertions, 4 deletions
diff --git a/src/configure.in b/src/configure.in
index 4bb49a70af..90a17ac847 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1938,10 +1938,30 @@ AC_ARG_ENABLE(netbeans,
, [enable_netbeans="yes"])
if test "$enable_netbeans" = "yes"; then
AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+fi
+
+AC_MSG_CHECKING(--disable-channel argument)
+AC_ARG_ENABLE(channel,
+ [ --disable-channel Disable process communication support.],
+ , [enable_channel="yes"])
+if test "$enable_channel" = "yes"; then
+ AC_MSG_RESULT(no)
+else
+ if test "$enable_netbeans" = "yes"; then
+ AC_MSG_RESULT(yes, netbeans also disabled)
+ enable_netbeans="no"
+ else
+ AC_MSG_RESULT(yes)
+ fi
+fi
+
+if "$enable_channel" = "yes"; then
dnl On Solaris we need the socket and nsl library.
AC_CHECK_LIB(socket, socket)
AC_CHECK_LIB(nsl, gethostbyname)
- AC_MSG_CHECKING(whether compiling netbeans integration is possible)
+ AC_MSG_CHECKING(whether compiling with process communication is possible)
AC_TRY_LINK([
#include <stdio.h>
#include <stdlib.h>
@@ -1967,9 +1987,7 @@ if test "$enable_netbeans" = "yes"; then
(void)connect(1, (struct sockaddr *)&server, sizeof(server));
],
AC_MSG_RESULT(yes),
- AC_MSG_RESULT(no); enable_netbeans="no")
-else
- AC_MSG_RESULT(yes)
+ AC_MSG_RESULT(no); enable_netbeans="no"; enable_channel="no")
fi
if test "$enable_netbeans" = "yes"; then
AC_DEFINE(FEAT_NETBEANS_INTG)
@@ -1978,6 +1996,13 @@ if test "$enable_netbeans" = "yes"; then
NETBEANS_OBJ="objects/netbeans.o"
AC_SUBST(NETBEANS_OBJ)
fi
+if test "$enable_channel" = "yes"; then
+ AC_DEFINE(FEAT_CHANNEL)
+ CHANNEL_SRC="channel.c"
+ AC_SUBST(CHANNEL_SRC)
+ CHANNEL_OBJ="objects/channel.o"
+ AC_SUBST(CHANNEL_OBJ)
+fi
AC_MSG_CHECKING(--enable-sniff argument)
AC_ARG_ENABLE(sniff,