summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2014-08-17 17:05:44 +0200
committerBram Moolenaar <Bram@vim.org>2014-08-17 17:05:44 +0200
commitd5f62b14e1d70f23866e613449ca71ac0b903e0f (patch)
tree3168d58cf5ba63c417532e034ff83ea590bc119f /src/configure.in
parent2a5868ab1ec14668aa7499477c57895064766eff (diff)
updated for version 7.4.409v7.4.409
Problem: Can't build with Perl on Fedora 20. Solution: Find xsubpp in another directory. (Michael Henry)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index 1cee1e61d1..62785e171c 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -933,6 +933,14 @@ if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
fi
vi_cv_perllib=`$vi_cv_path_perl -MConfig -e 'print $Config{privlibexp}'`
AC_SUBST(vi_cv_perllib)
+ vi_cv_perl_extutils=unknown_perl_extutils_path
+ for extutils_rel_path in ExtUtils vendor_perl/ExtUtils; do
+ xsubpp_path="$vi_cv_perllib/$extutils_rel_path/xsubpp"
+ if test -f "$xsubpp_path"; then
+ vi_cv_perl_xsubpp="$xsubpp_path"
+ fi
+ done
+ AC_SUBST(vi_cv_perl_xsubpp)
dnl Remove "-fno-something", it breaks using cproto.
perlcppflags=`$vi_cv_path_perl -Mlib=$srcdir -MExtUtils::Embed \
-e 'ccflags;perl_inc;print"\n"' | sed -e 's/-fno[[^ ]]*//'`