summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2014-04-10 11:09:17 +0200
committerBram Moolenaar <Bram@vim.org>2014-04-10 11:09:17 +0200
commitc09551ab796af1f8aa19338d99e49267860fcd9c (patch)
treea529fedaab7e2165481ecc8e87497a492e80b6d6 /src/configure.in
parent5a4e160ce423f56456227c3d7d8d8a069120b377 (diff)
updated for version 7.4.254v7.4.254
Problem: Smack support detection is incomplete. Solution: Check for attr/xattr.h and specific macro.
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/configure.in b/src/configure.in
index b22b9ea5cd..e97878012e 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -396,10 +396,19 @@ if test "$enable_smack" = "yes"; then
AC_MSG_RESULT(no)
AC_CHECK_HEADER([linux/xattr.h], true, enable_smack="no")
else
- AC_MSG_RESULT(yes)
+ AC_MSG_RESULT(yes)
+fi
+if test "$enable_smack" = "yes"; then
+ AC_CHECK_HEADER([attr/xattr.h], true, enable_smack="no")
+fi
+if test "$enable_smack" = "yes"; then
+ AC_MSG_CHECKING(for XATTR_NAME_SMACKEXEC in linux/xattr.h)
+ AC_EGREP_CPP(XATTR_NAME_SMACKEXEC, [#include <linux/xattr.h>],
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no); enable_smack = "no")
fi
if test "$enable_smack" = "yes"; then
- AC_CHECK_LIB(attr, llistxattr,
+ AC_CHECK_LIB(attr, setxattr,
[LIBS="$LIBS -lattr"
found_smack="yes"
AC_DEFINE(HAVE_SMACK)])