summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2016-01-28 15:34:25 +0100
committerBram Moolenaar <Bram@vim.org>2016-01-28 15:34:25 +0100
commitba59ddbd3642d02614acbe52694e3e8a78c0e9d3 (patch)
tree81592a2f20ab2cfcd17b1381fc121951ac209da6 /src/configure.in
parent923e43b837ca4c8edb7998743f142823eaeaf588 (diff)
patch 7.4.1190v7.4.1190
Problem: On OSX the default flag for dlopen() is different. Solution: Add RTLD_LOCAL in the configure check. (sv99, closes #604)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/configure.in b/src/configure.in
index e9ffa7bb19..ffa0b2ded1 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1219,7 +1219,7 @@ eof
vi_cv_path_python_plibs=`echo $vi_cv_path_python_plibs | sed s/-ltermcap//`
fi
])
- AC_CACHE_VAL(vi_cv_dll_name_python,
+ AC_CACHE_CHECK(Python's dll name,vi_cv_dll_name_python,
[
if test "X$python_DLLLIBRARY" != "X"; then
vi_cv_dll_name_python="$python_DLLLIBRARY"
@@ -1428,7 +1428,7 @@ eof
vi_cv_path_python3_plibs=`echo $vi_cv_path_python3_plibs | sed s/-ltermcap//`
vi_cv_path_python3_plibs=`echo $vi_cv_path_python3_plibs | sed s/-lffi//`
])
- AC_CACHE_VAL(vi_cv_dll_name_python3,
+ AC_CACHE_CHECK(Python3's dll name,vi_cv_dll_name_python3,
[
if test "X$python3_DLLLIBRARY" != "X"; then
vi_cv_dll_name_python3="$python3_DLLLIBRARY"
@@ -1540,7 +1540,7 @@ if test "$python_ok" = yes && test "$python3_ok" = yes; then
int no_rtl_global_needed_for(char *python_instsoname, char *prefix)
{
int needed = 0;
- void* pylib = dlopen(python_instsoname, RTLD_LAZY);
+ void* pylib = dlopen(python_instsoname, RTLD_LAZY|RTLD_LOCAL);
if (pylib != 0)
{
void (*pfx)(char *home) = dlsym(pylib, "Py_SetPythonHome");
@@ -1586,7 +1586,7 @@ if test "$python_ok" = yes && test "$python3_ok" = yes; then
int no_rtl_global_needed_for(char *python_instsoname, wchar_t *prefix)
{
int needed = 0;
- void* pylib = dlopen(python_instsoname, RTLD_LAZY);
+ void* pylib = dlopen(python_instsoname, RTLD_LAZY|RTLD_LOCAL);
if (pylib != 0)
{
void (*pfx)(wchar_t *home) = dlsym(pylib, "Py_SetPythonHome");