summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2014-02-23 22:52:40 +0100
committerBram Moolenaar <Bram@vim.org>2014-02-23 22:52:40 +0100
commita2aa31a9269641839178b0c0663dc67405c33d3e (patch)
treefba5b26febe0f352a4ad0a9cace397f479ced86c /src/configure.in
parent7d311c52ce2859f67532e0a4b604eb8147473c01 (diff)
updated for version 7.4.188v7.4.188
Problem: SIZEOF_LONG clashes with similar defines in header files. Solution: Rename to a name starting with VIM_. Also for SIZEOF_INT.
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index bc8b6eb8cf..cf693505a0 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -3581,6 +3581,10 @@ AC_CHECK_SIZEOF([long])
AC_CHECK_SIZEOF([time_t])
AC_CHECK_SIZEOF([off_t])
+dnl Use different names to avoid clashing with other header files.
+AC_DEFINE_UNQUOTED(VIM_SIZEOF_INT, [$ac_cv_sizeof_int])
+AC_DEFINE_UNQUOTED(VIM_SIZEOF_LONG, [$ac_cv_sizeof_long])
+
dnl Make sure that uint32_t is really 32 bits unsigned.
AC_MSG_CHECKING([uint32_t is 32 bits])
AC_TRY_RUN([