summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2015-03-24 15:14:27 +0100
committerBram Moolenaar <Bram@vim.org>2015-03-24 15:14:27 +0100
commita161e26d558204311f6e76208fa4cd3b2dbbab0b (patch)
tree87e5938cec264281dd12cb0329b15d4dbc2834eb /src/configure.in
parent6c927557e2b0b2fbc2dfc91f604bf1117d0bf77a (diff)
updated for version 7.4.677v7.4.677
Problem: Configure fails when specifying a python-config-dir. (Lcd) Solution: Check if PYTHONFRAMEWORKPREFIX is set.
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.in b/src/configure.in
index 9d8121530e..be3c6587fe 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1148,7 +1148,7 @@ eof
dnl -- Check if the path contained in python_LINKFORSHARED is
dnl usable for vim build. If not, make and try other
dnl candidates.
- if test -n "${python_LINKFORSHARED}"; then
+ if test -n "${python_LINKFORSHARED}" && test -n "${python_PYTHONFRAMEWORKPREFIX}"; then
python_link_symbol=`echo ${python_LINKFORSHARED} | sed 's/\([[^ \t]][[^ \t]]*[[ \t]][[ \t]]*[[^ \t]][[^ \t]]*\)[[ \t]].*/\1/'`
python_link_path=`echo ${python_LINKFORSHARED} | sed 's/\([[^ \t]][[^ \t]]*[[ \t]][[ \t]]*[[^ \t]][[^ \t]]*\)[[ \t]][[ \t]]*\(.*\)/\2/'`
if test -n "${python_link_path}" && ! test -x "${python_link_path}"; then