summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2015-03-05 16:47:20 +0100
committerBram Moolenaar <Bram@vim.org>2015-03-05 16:47:20 +0100
commit5d3fbf3bfea3b698f42a44c2732e58fa63f01446 (patch)
tree3838388ff696be1beba55c55fb299e403a07367b /src/configure.in
parentcf48767cd17130958a3076eed1872b6950947a0a (diff)
updated for version 7.4.650v7.4.650
Problem: Configure check may fail because the dl library is not used. Solution: Put "-ldl" in LIBS rather than LDFLAGS. (Oazki Kiichi)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/configure.in b/src/configure.in
index 033138c115..7fa4297393 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1451,9 +1451,9 @@ if test "$python_ok" = yes && test "$python3_ok" = yes; then
AC_MSG_CHECKING(whether we can do without RTLD_GLOBAL for Python)
cflags_save=$CFLAGS
CFLAGS="$CFLAGS $PYTHON_CFLAGS"
- ldflags_save=$LDFLAGS
+ libs_save=$LIBS
dnl -ldl must go first to make this work on Archlinux (Roland Puntaier)
- LDFLAGS="-ldl $LDFLAGS"
+ LIBS="-ldl $LIBS"
AC_RUN_IFELSE([AC_LANG_SOURCE([
#include <dlfcn.h>
/* If this program fails, then RTLD_GLOBAL is needed.
@@ -1491,14 +1491,14 @@ if test "$python_ok" = yes && test "$python3_ok" = yes; then
[AC_MSG_RESULT(yes);AC_DEFINE(PY_NO_RTLD_GLOBAL)], [AC_MSG_RESULT(no)])
CFLAGS=$cflags_save
- LDFLAGS=$ldflags_save
+ LIBS=$libs_save
AC_MSG_CHECKING(whether we can do without RTLD_GLOBAL for Python3)
cflags_save=$CFLAGS
CFLAGS="$CFLAGS $PYTHON3_CFLAGS"
- ldflags_save=$LDFLAGS
+ libs_save=$LIBS
dnl -ldl must go first to make this work on Archlinux (Roland Puntaier)
- LDFLAGS="-ldl $LDFLAGS"
+ LIBS="-ldl $LIBS"
AC_RUN_IFELSE([AC_LANG_SOURCE([
#include <dlfcn.h>
#include <wchar.h>
@@ -1537,7 +1537,7 @@ if test "$python_ok" = yes && test "$python3_ok" = yes; then
[AC_MSG_RESULT(yes);AC_DEFINE(PY3_NO_RTLD_GLOBAL)], [AC_MSG_RESULT(no)])
CFLAGS=$cflags_save
- LDFLAGS=$ldflags_save
+ LIBS=$libs_save
PYTHON_SRC="if_python.c"
PYTHON_OBJ="objects/if_python.o"