summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2015-06-21 13:41:08 +0200
committerBram Moolenaar <Bram@vim.org>2015-06-21 13:41:08 +0200
commit280a868a246eda3904eb925588f111b69e304878 (patch)
tree6681f47c683ae7fb6b159e652bac02e098d61962 /src/configure.in
parent0e7c4b99c608d22fd1b8526e700420b248319b1f (diff)
patch 7.4.750v7.4.750
Problem: Cannot build with clang 3.5 on Cygwin with perl enabled. Solution: Strip "-fdebug-prefix-map" in configure. (Ken Takata)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/configure.in b/src/configure.in
index be3c6587fe..80d70b0e50 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -942,8 +942,10 @@ if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
done
AC_SUBST(vi_cv_perl_xsubpp)
dnl Remove "-fno-something", it breaks using cproto.
+ dnl Remove "-fdebug-prefix-map", it isn't supported by clang.
perlcppflags=`$vi_cv_path_perl -Mlib=$srcdir -MExtUtils::Embed \
- -e 'ccflags;perl_inc;print"\n"' | sed -e 's/-fno[[^ ]]*//'`
+ -e 'ccflags;perl_inc;print"\n"' | sed -e 's/-fno[[^ ]]*//' \
+ -e 's/-fdebug-prefix-map[[^ ]]*//g'`
dnl Remove "-lc", it breaks on FreeBSD when using "-pthread".
perllibs=`cd $srcdir; $vi_cv_path_perl -MExtUtils::Embed -e 'ldopts' | \
sed -e '/Warning/d' -e '/Note (probably harmless)/d' \