summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2014-11-30 13:34:23 +0100
committerBram Moolenaar <Bram@vim.org>2014-11-30 13:34:23 +0100
commit0b105416066c95ade3604ec2139d8367d3c6e74e (patch)
tree00c20ce83fa5316d76e6df05b5755e3cbe5f156e /src/configure.in
parent76440e2efe9e3582e9943d01183ec8b2f3e4eb4b (diff)
updated for version 7.4.538v7.4.538
Problem: Tests fail with small features plus Python. Solution: Disallow weird combination of options. Do not set "fdm" when folding is disabled.
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index ff1f4824b4..033138c115 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1041,6 +1041,10 @@ AC_ARG_ENABLE(pythoninterp,
[enable_pythoninterp="no"])
AC_MSG_RESULT($enable_pythoninterp)
if test "$enable_pythoninterp" = "yes" -o "$enable_pythoninterp" = "dynamic"; then
+ if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ AC_MSG_ERROR([cannot use Python with tiny or small features])
+ fi
+
dnl -- find the python executable
AC_PATH_PROGS(vi_cv_path_python, python2 python)
if test "X$vi_cv_path_python" != "X"; then
@@ -1243,6 +1247,10 @@ AC_ARG_ENABLE(python3interp,
[enable_python3interp="no"])
AC_MSG_RESULT($enable_python3interp)
if test "$enable_python3interp" = "yes" -o "$enable_python3interp" = "dynamic"; then
+ if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ AC_MSG_ERROR([cannot use Python with tiny or small features])
+ fi
+
dnl -- find the python3 executable
AC_PATH_PROGS(vi_cv_path_python3, python3 python)
if test "X$vi_cv_path_python3" != "X"; then
@@ -1720,6 +1728,10 @@ AC_ARG_ENABLE(rubyinterp,
[enable_rubyinterp="no"])
AC_MSG_RESULT($enable_rubyinterp)
if test "$enable_rubyinterp" = "yes" -o "$enable_rubyinterp" = "dynamic"; then
+ if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ AC_MSG_ERROR([cannot use Ruby with tiny or small features])
+ fi
+
AC_MSG_CHECKING(--with-ruby-command argument)
AC_SUBST(vi_cv_path_ruby)
AC_ARG_WITH(ruby-command, [ --with-ruby-command=RUBY name of the Ruby command (default: ruby)],