summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorKelvin Lee <kiyolee@gmail.com>2022-04-04 17:20:01 +0100
committerBram Moolenaar <Bram@vim.org>2022-04-04 17:20:01 +0100
commitb471690fad5f40f74aca488b13669641fb2b9de1 (patch)
tree798a6e73aa2dc40e44e357d2a736639731809a3e /src/configure.ac
parent188639d75c363dffaf813e8e2209f7350ad1e871 (diff)
patch 8.2.4686: configure doesn't find the Motif library with Cygwinv8.2.4686
Problem: Configure doesn't find the Motif library with Cygwin. Solution: Check for libXm.dll.a. (Kelvin Lee, closes #10077)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 1426e74c5e..913129f665 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2965,11 +2965,12 @@ if test -z "$SKIP_MOTIF"; then
dnl Ubuntu has libXm.so in /usr/lib/i386-linux-gnu and elsewhere. The
dnl linker will figure out which one to use, we only check if one exists.
+ dnl Cygwin uses the .dll.a extension.
AC_MSG_CHECKING(for location of Motif GUI libs)
gui_libs="`echo $x_libraries|sed 's%/[^/][^/]*$%%'` `echo "$gui_XXX" | sed s/XXX/lib/g` /usr/lib/i386-linux-gnu /usr/lib/x86_64-linux-gnu `echo "$GUI_INC_LOC" | sed s/include/lib/` $GUI_LIB_LOC"
GUI_LIB_LOC=
for try in $gui_libs; do
- for libtry in "$try"/libXm.a "$try"/libXm.so* "$try"/libXm.sl "$try"/libXm.dylib; do
+ for libtry in "$try"/libXm.a "$try"/libXm.dll.a "$try"/libXm.so* "$try"/libXm.sl "$try"/libXm.dylib; do
if test -f "$libtry"; then
GUI_LIB_LOC=$try
fi