summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorzeertzjq <zeertzjq@outlook.com>2023-09-30 14:19:14 +0200
committerChristian Brabandt <cb@256bit.org>2023-09-30 14:22:07 +0200
commit6de4e58cf27a3bb6e81653ca63b77e29d1bb46f2 (patch)
treef888ce152822399935cdc31dc1fe5eed594a9769 /src/configure.ac
parente085dfda5d8dde064b0332464040959479696d1c (diff)
patch 9.0.1963: Configure script may not detect xattrv9.0.1963
Problem: Configure script may not detect xattr correctly Solution: include sys/xattr instead of attr/xattr, make Test_write_with_xattr_support() test xattr feature correctly This also applies to the Smack security feature, so change the include and configure script for it as well. closes: #13229 Signed-off-by: Christian Brabandt <cb@256bit.org> Co-authored-by: zeertzjq <zeertzjq@outlook.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index e21e23490a..4b2046dd52 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -480,7 +480,7 @@ else
AC_MSG_RESULT(yes)
fi
if test "$enable_smack" = "yes"; then
- AC_CHECK_HEADER([attr/xattr.h], true, enable_smack="no")
+ AC_CHECK_HEADER([sys/xattr.h], true, enable_smack="no")
fi
if test "$enable_smack" = "yes"; then
AC_MSG_CHECKING(for XATTR_NAME_SMACKEXEC in linux/xattr.h)
@@ -520,7 +520,7 @@ AC_ARG_ENABLE(xattr,
, enable_xattr="yes")
if test "$enable_xattr" = "yes"; then
AC_MSG_RESULT(yes)
- AC_CHECK_HEADER([attr/xattr.h], [AC_DEFINE(HAVE_XATTR)])
+ AC_CHECK_HEADER([sys/xattr.h], [AC_DEFINE(HAVE_XATTR)])
else
AC_MSG_RESULT(no)
fi