summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorYee Cheng Chin <ychin.git@gmail.com>2023-04-05 18:24:50 +0100
committerBram Moolenaar <Bram@vim.org>2023-04-05 18:24:50 +0100
commitb6ebe5af74a965d703eb8ee66a07c97b0bbe6e58 (patch)
tree2206b7d36e29e5c055e1852288077e28d6ae5f99 /src/configure.ac
parent23a971da506249fc8388f06cd5c011b83406ac5c (diff)
patch 9.0.1441: MacOS: Python 3 using framework do not set dll name properlyv9.0.1441
Problem: MacOS: Python 3 using framework do not set dll name properly. Solution: Use the framework prefix. (Yee Cheng Chin, closes #12189)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 94e186382d..ec4141dc87 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1584,6 +1584,7 @@ __:
@echo "python3_SYSLIBS='$(SYSLIBS)'"
@echo "python3_DLLLIBRARY='$(DLLLIBRARY)'"
@echo "python3_INSTSONAME='$(INSTSONAME)'"
+ @echo "python3_PYTHONFRAMEWORKPREFIX='$(PYTHONFRAMEWORKPREFIX)'"
eof
dnl -- delete the lines from make about Entering/Leaving directory
eval "`cd ${PYTHON3_CONFDIR} && make -f "${tmp_mkf}" __ | sed '/ directory /d'`"
@@ -1598,6 +1599,8 @@ eof
[
if test "X$python3_DLLLIBRARY" != "X"; then
vi_cv_dll_name_python3="$python3_DLLLIBRARY"
+ elif test "X$python3_PYTHONFRAMEWORKPREFIX" != "X"; then
+ vi_cv_dll_name_python3="${python3_PYTHONFRAMEWORKPREFIX}/${python3_INSTSONAME}"
else
vi_cv_dll_name_python3="$python3_INSTSONAME"
fi