summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2023-04-12 16:24:03 +0100
committerBram Moolenaar <Bram@vim.org>2023-04-12 16:24:03 +0100
commit01967f5b1042b375b38098eceaf31671902c8dbb (patch)
treefb0f636a7310e4028e22049158b54b87cf96c86d /src/configure.ac
parentac6cd31afcbdd08bfa92ca33f7d4ce5773ba4353 (diff)
patch 9.0.1445: openSUSE: configure doesn't find the Motif libraryv9.0.1445
Problem: openSUSE: configure doesn't find the Motif library. (Tony Mechelynck) Solution: Also search in /usr/lib64.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index ec4141dc87..0c776a2c42 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2976,8 +2976,9 @@ if test -z "$SKIP_MOTIF"; then
dnl Ubuntu has libXm.so in /usr/lib/i386-linux-gnu and elsewhere. The
dnl linker will figure out which one to use, we only check if one exists.
dnl Cygwin uses the .dll.a extension.
+ dnl OpenSUSE appears to use /usr/lib64.
AC_MSG_CHECKING(for location of Motif GUI libs)
- gui_libs="`echo $x_libraries|sed 's%/[^/][^/]*$%%'` `echo "$gui_XXX" | sed s/XXX/lib/g` /usr/lib/i386-linux-gnu /usr/lib/x86_64-linux-gnu `echo "$GUI_INC_LOC" | sed s/include/lib/` $GUI_LIB_LOC"
+ gui_libs="`echo $x_libraries|sed 's%/[^/][^/]*$%%'` `echo "$gui_XXX" | sed s/XXX/lib/g` /usr/lib64 /usr/lib/i386-linux-gnu /usr/lib/x86_64-linux-gnu `echo "$GUI_INC_LOC" | sed s/include/lib/` $GUI_LIB_LOC"
GUI_LIB_LOC=
for try in $gui_libs; do
for libtry in "$try"/libXm.a "$try"/libXm.dll.a "$try"/libXm.so* "$try"/libXm.sl "$try"/libXm.dylib; do
@@ -2987,8 +2988,10 @@ if test -z "$SKIP_MOTIF"; then
done
done
if test -n "$GUI_LIB_LOC"; then
- dnl Remove /usr/lib, it causes trouble on some systems
+ dnl Remove /usr/lib, it causes trouble on some systems.
+ dnl For consistency also remove other standard lib directories.
if test "$GUI_LIB_LOC" = /usr/lib \
+ -o "$GUI_LIB_LOC" = /usr/lib64 \
-o "$GUI_LIB_LOC" = /usr/lib/i386-linux-gnu \
-o "$GUI_LIB_LOC" = /usr/lib/x86_64-linux-gnu; then
GUI_LIB_LOC=