summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-04-15 16:03:25 +0200
committerBram Moolenaar <Bram@vim.org>2018-04-15 16:03:25 +0200
commite1a32310d5e9684608b893ab8295191d63178b4e (patch)
tree3d3df0eafb03922a47f9f710e7498fa9dca82988 /src/configure.ac
parent6c672194cd06fb1ab1289475aad31a9769bdb2ad (diff)
patch 8.0.1719: cannot specify which Python executable configure should usev8.0.1719
Problem: Cannot specify which Python executable configure should use. Solution: Add --with-python-command and --with-python3-command.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac24
1 files changed, 20 insertions, 4 deletions
diff --git a/src/configure.ac b/src/configure.ac
index ff0c726fc6..e37a26790f 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1117,7 +1117,15 @@ if test "$enable_pythoninterp" = "yes" -o "$enable_pythoninterp" = "dynamic"; th
fi
dnl -- find the python executable
- AC_PATH_PROGS(vi_cv_path_python, python2 python)
+ AC_MSG_CHECKING(--with-python-command argument)
+ AC_SUBST(vi_cv_path_python)
+ AC_ARG_WITH(python-command, [ --with-python-command=NAME name of the Python 2 command (default: python2 or python)],
+ vi_cv_path_python="$withval"; AC_MSG_RESULT($vi_cv_path_python),
+ AC_MSG_RESULT(no))
+
+ if test "X$vi_cv_path_python" = "X"; then
+ AC_PATH_PROGS(vi_cv_path_python, python2 python)
+ fi
if test "X$vi_cv_path_python" != "X"; then
dnl -- get its version number
@@ -1156,7 +1164,7 @@ if test "$enable_pythoninterp" = "yes" -o "$enable_pythoninterp" = "dynamic"; th
dnl -- where the Python implementation library archives are
AC_ARG_WITH(python-config-dir,
- [ --with-python-config-dir=PATH Python's config directory],
+ [ --with-python-config-dir=PATH Python's config directory (deprecated)],
[ vi_cv_path_python_conf="${withval}"; have_python_config_dir=1 ] )
AC_CACHE_CHECK(Python's configuration directory,vi_cv_path_python_conf,
@@ -1343,7 +1351,15 @@ if test "$enable_python3interp" = "yes" -o "$enable_python3interp" = "dynamic";
fi
dnl -- find the python3 executable
- AC_PATH_PROGS(vi_cv_path_python3, python3 python)
+ AC_MSG_CHECKING(--with-python3-command argument)
+ AC_SUBST(vi_cv_path_python3)
+ AC_ARG_WITH(python3-command, [ --with-python3-command=NAME name of the Python 3 command (default: python3 or python)],
+ vi_cv_path_python3="$withval"; AC_MSG_RESULT($vi_cv_path_python3),
+ AC_MSG_RESULT(no))
+
+ if test "X$vi_cv_path_python3" = "X"; then
+ AC_PATH_PROGS(vi_cv_path_python3, python3 python)
+ fi
if test "X$vi_cv_path_python3" != "X"; then
dnl -- get its version number
@@ -1393,7 +1409,7 @@ if test "$enable_python3interp" = "yes" -o "$enable_python3interp" = "dynamic";
dnl -- where the Python implementation library archives are
AC_ARG_WITH(python3-config-dir,
- [ --with-python3-config-dir=PATH Python's config directory],
+ [ --with-python3-config-dir=PATH Python's config directory (deprecated)],
[ vi_cv_path_python3_conf="${withval}"; have_python3_config_dir=1 ] )
AC_CACHE_CHECK(Python's configuration directory,vi_cv_path_python3_conf,